Cisco Catalyst3750交换机培训
ISMP项目组
2008.2
1、产品概述

思科新推出的Cisco Catalyst 3750系列交换机是一个创新的产品系列,它结合业界领先的易用性和最高的冗余性,里程碑地提升了堆叠式交换机在局域网中的工作效率。这个新的产品系列采 用了最新的思科StackWise技术,不但实现高达32Gbps的堆叠互联,还从物理上到逻辑上使若干独立交换机在堆叠时集成在一起,便于用户建立一个 统一、高度灵活的交换系统–就好像是一整台交换机一样。这代表了堆叠式交换机新的工业技术水平和标准。
对于中型组织和企业分支机构而言,Cisco Catalyst 3750系列可以通过提供配置灵活性,支持融合网络模式,已经自动配置智能化网络服务,降低融合应用的部署难度,适应不断变化的业务需求。此外, Cisco Catalyst 3750系列针对高密度千兆位以太网部署进行了专门的优化,其中包含多种可以满足接入、汇聚或者小型网络骨干网连接需求的交换机。
Cisco Catalyst 3750系列交换机为服务器集群提供千兆位互联
2、ISMP平台Cisco3750部署拓扑

3、
Cisco Catalyst 3750G-48TS
48个Ethernet 10/100/1000 ports and 4 SFP uplinks

Cisco Catalyst 3750-48TS
48个以太网10/100端口和4条SFP上行链路
ISMP平台Cisco3750配置清单

4、访问交换机
基本管理配置
以太网端口的配置
以太网端口的配置
VLAN配置
Trunk配置
VTP配置
STP协议
Cisco3750基本配置步骤

5、访问交换机

通过console访问交换机
通过Telnet访问交换机
6、通过console访问

7、通过Telnet访问

1、配置管理VLAN接口的IP地址(ip address命令)
2、指定与终端相连的以太网端口属于该VLAN(VLAN模式下使用switchport命令)
3、配置登录Telnet用户授权验证
switch> enable
Password:
switch# configure terminal
Enter configuration commands, one per line. End with Ctrl+Z.
switch (config)# line vty 0 4
switch (config-line)# password xxxx(xxxx是Telnet用户登录口令)
switch (config-line)# exit
switch (config)# enable password xxxx(xxxx特权用户模式的口令)
4、运行Telnet程序与以太网交换机建立Telnet连接

8、设置交换机名字
设置交换机管理IP地址
设置交换机时间信息
设置交换机的密码
设置交换机的日志信息
设置交换机的snmp信息

基本管理配置

9
switch(config)#hostname ASB-3750-a
ASB-3750-a(config)#
设置交换机名字

10
设置交换机管理IP地址

switch(config)#interface vlan1
switch(config)#ip address 10.1.1.1 255.255.255.0
switch(config-if)#no shutdown
switch(config-if)#exit
switch#show run
…..
interface Vlan1
ip address 139.118.4.2 255.255.252.0
….
//配置交换机的缺省网关,三层用不配.
switch(config)#ip default-gateway 10.1.1.255

11
switch#show clock
* 18:37:04.104 UTC Mon Jul 30 2008
switch# clock set 9:00:00 Jan 1 2001
switch#show clock
09:00:04.123 UTC Mon Jan 1 2008

设置交换机时间信息

12
# 使用secret口令,不使用password口令
switch(config)# enable secret ASB
switch(config)#exit
switch#show running-config
……….
Enable secret 5 $1228899030dieiiop
……….
#同样配置telnet和console的口令,并加密(service password-encryption).
switch(config)# service password-encryption
switch(config)#line console 0
switch(config-line)#password xxxxxx
switch(config-line)#line vty 0 4
switch(config-line)#password yyyyyy
switch(config-line)#login
switch(cnfig-line)#end

设置交换机的密码

13
输出 : 分为Console、Telnet、Buffer、Host四个方向。
日志等级分为8级,0级最高.使用logging buffer level 修改记录等级。
emergency 0 紧急:系统不可用
alert 1 告警:需要立即行动
critical 2 关键:关键状态
error 3 错误:错误状态
warning 4 警告:警告状态
notification 5 通知:正常但重要状态
informational 6 信息:仅是信息消息
debug 7 调试:调试消息

switch(config)#logging buffered //把日志记录到buffer中的配置命令.
switch(config)#logging buffered informational //等级为6,informational
switchr(config)#show logging //显示buffer中的logging信息.
switch(config)# service timestamps log datetime //给日志信息打时间标记

设置交换机的日志信息

14
switch(config)# access-list 10 permit 172.18.129.100 log
//配置snmp访问控制列表
switch(config)# snmp-server community ********** RW 10
//配置读写字符串
switch(config)# snmp-server trap-source Vlan1000
//配置trap的源地址
switch(config)# snmp-server host 172.18.129.100 **********
//配置接收trap的主机地址及特定字符串
设置交换机的snmp信息

15
打开/关闭以太网端口
设置以太网端口的描述
设置以太网端口的双工状态
设置以太网端口的速率
设置以太网端口的工作模式

以太网端口的配置

16

Switch(config)#interface fastethernet 0/1
Switch(config-if)#shutdown //关闭端口
Switch(config)#interface fastethernet 0/1
Switch(config-if))#no shutdown //打开端口

//缺省状态下,端口是关闭的

打开/关闭以太网端口

17

# 描述命令说明了以太网端口的作用.
Switch(config)#interface fastethernet 0/1
Switch(config-if)#description : connected to CC1

设置以太网端口的描述

18

Switch(config)#interface fastethernet 0/1
Switch(config-if)# duplex { half | full | auto }
//其中half为半双工,full为全双工,auto为自动协商。

设置以太网端口的双工状态

19

Switch(config)#interface fastethernet 0/1
Switch(config-if)# speed { 10 | 100 | 1000 | auto}
//其中10为10M,100为100M,1000为1000M,auto为自动协商。

Switch(config-if)#no speed
//恢复端口缺省速率配置。

设置以太网端口的速率

20

// 指明端口工作在access模式下
Switch(config-if)#switchport mode access
//指明端口工作在trunk模式下
Switch(config-if)#switchport mode trunk

说明 :
0、以太网端口有二种工作模式:Access和Trunk。
1、端口工作在Access模式下只能属于1个VLAN,一般用于接用户计算机的端口;
2、端口工作在Trunk模式下可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
3、可以使用switchport access vlan vlan_number指明端口属于什么vlan。
设置以太网端口的工作模式

21

switch(config)#interface fastethernet 0/1

switch(config-if)# channel- group channel-group-number mode {auto [non-silent] | desirable [non-silent] | on}

注意 :
1、快速以太网信道链路上的所有端口必须是同一个VLAN的成员,或者必须是Trunk端口。
2、如果快速以太网信道链路内的端口是trunk端口,则这些端口必须有相同的vlan范围。
3、快速以太网信道链路内的所有端口的速度和双工模式设置必须相同。

链路聚合(EtherChannel)
22

switch(config)#interface GigabitEthernet1/0/2
switch(config-if)# switchport trunk encapsulation dot1q
switch(config-if)# switchport mode trunk
1、接入(access)链路:接入链路只是一个VLAN的成员。这个VLAN被称为端口的本地VLAN。连接到这个端口上的设备完全不知道存着一个VLAN。设备只是根据被配置在该设备上的第3层信息认为它是网络或子网的一部分。为了保证使它不需要知道VLAN的存在,交换机负责在帧被发送到未端设备之前将VLAN信息从帧中拿掉。接入链路是属于一个、并且只属于一个VLAN的端口,这个端口不能从另一个VLAN接收信息,除非该信息已经选择过路由了。这个端口也不能发送信息到另一个VLAN,除非这个端口可以访问路由器。
2、干道(trunk)链路:干道链路可以承载多个VLAN。干道链路的得名是来自电话系统中的干道(trunk),它们能够传输多个电话对话。干道链路通常被用来将交换机连接到其他交换机,或者将交换机连接到路由器。Cisco在快速以太网和千兆以太网端口上支持干道链路。
目前Cisco所使用的有两种标识技术如下:
 a、Cisco交换机间链路(ISL): 用于互连多台交换机的cisco专有封装协议。该该协议在 Catalyst 交换机和路由器上被支持
 b、IEEE802.1Q标准:它通过 在帧头插入一个VLAN标识符来标识VLAN。

Trunk配置

23
//创建vlan
switch#vlan database
switch(config-vlan)# vlan valn_id name vlan_name
switch(config-vlan)# no vlan vlan_id

//创建三层vlan
switch(config)# interface vlan_id
switch(config-vlan)# ip address 172.168.1.1 255.255.255.0
switch(config-vlan)# no shutdown

//端口加入vlan
switch(config)# interface g1/0/10
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan vlan_id
Switch(config-if)#no shutdown

查看命令:show vlan、show interface vlan

VLAN配置
24
//主交换机上standby的配置
interface Vlan10
description “uplink”
ip address 172.18.128.53 255.255.255.248
standby 10 ip 172.18.128.50 //standby_id=10,standby_ip= 172.18.128.50
standby 10 priority 105 //配置优先级,数值越大,优先级越高
standby 10 preempt //配置抢占模式

//从交换机上standby的配置
interface Vlan10
description “uplink”
ip address 172.18.128.54 255.255.255.248
standby 10 ip 172.18.128.50

查看命令:show standby

HSRP配置
25

switch#vlan database
switch(config-vlan)# vtp domain domain-name
switch(config-vlan)# vtp mode { server | client | transparent }

说明 :
1、VTP(VLAN Trunk Protocol,VLAN干道协议)的功能与GVRP(IEEE 802.1Q的标准协议)相同。
2、VTP Server维护该VTP域中所有VLAN信息列表,可以增加、删除或修改VLAN。
3、VTP Client也维护该VTP域中所有VLAN信息列表,但不能增加、删除或修改VLAN,任何变化的信息必须从VTP Server发布的通告报文中接收。
4、VTP Transparent不参与VTP工作,它虽然忽略所有接收到的VTP信息,但能够将接收到的VTP报文转发出去。它只拥有本设备上的VLAN信息。
5、其中,VTP Server和VTP Client必须处于同一个VTP域,且一个交换机只能位于一个VTP域中。
6、同一个VTP域内的所有交换机的域名必须相同;
7、同一个VTP域内的交换机必须邻接;
8、同一个VTP域内的邻接交换机之间的Trunk链路必须激活。
9、VTP的版本号是用来同步整个交换VLAN的信息的,只有VTP的Server上的高配置版本号才能同步低的,相同配置版本号的两个VLAN数据库不会更新对方,可以使用以下几种办法可以清除VTP的版本号:
a.将VTP的域名改掉,再改回来;
b.将VTP的版本号改掉,再改回来;
c.将VTP的模式改为透明模式,再改回来。

VTP配置
26
STP——生成树协议

STP的基本原理是,通过在交换机之间传递一种特殊的协议报文(IEEE 802.1D协议将这种协议报文称为“配置消息”)来确定网络的拓扑结构。配置消息中包含了足够的信息来保证交换机完成生成树计算。

配置消息中主要包括以下内容:
 树根的ID:由树根的优先级和MAC地址组合而成;
 到树根的最短路径开销;
 指定交换机的ID:由指定交换机的优先级和MAC地址组合而成;
 指定端口的ID:由指定端口的优先级和端口编号组成
 配置消息的生存期:MessageAge;
 配置消息的最大生存期:MaxAge;
 配置消息发送的周期:HelloTime;
 端口状态迁移的延时:ForwardDelay。

27
STP——生成树协议
//配置根网桥:
switch(config)# spanning-tree vlan vlan-id root primary [diameter net-diameter [hello-time seconds]]

//配置备用根网桥:
switch(config)# spanning-tree vlan vlan-id root secondary [diameter net-diameter [hello-time seconds]]

//修改端口优先级:
switch(config)#interface interface-id
switch(config-if)# spanning-tree port-priority priority

//修改端口路径开销:
switch(config)#interface interface-id
switch(config-if)# spanning-tree cost cost

28
静态路由配置
Cisco3750支持OSPF、BGP等动态路由协议。ISMP系统平台网络结构一般不复杂,配置静态路由即可。默认路由示例:
ip route 0.0.0.0 0.0.0.0 172.18.128.49

29
谢 谢!
30

发表评论

电子邮件地址不会被公开。 必填项已用*标注